New Member Area New to Monte Carlo Forum? Stop in tell us about you.

2000 monte ss

  #1  
Old 07-14-2018, 12:57 PM
Thread Starter
Join Date: May 2017
Posts: 4
Default 2000 monte ss

daylights and turn signals stop working, I lost on this one. help!
 
  #2  
Old 07-14-2018, 01:24 PM
drivernumber3's Avatar
Monte Of The Month -- May 2015
Monte Of The Month -- March 2017
5 Year Member
3 Year Member1 Year Member
Join Date: May 2013
Location: Nebraska
Posts: 4,160
Smile

Check the fuses to make sure they are still up.
Check the switch to make sure the wires are connected

Make sure the wires are not corroded

This could be a switch that needs to be replaced


I am assuming that you have not checked those items if you have then. You have completed all the steps. Obvious stuff like the bulbs?

You might want to see if a local salvage yard near by has a switch that you can liberate from another car like yours and replace it.

Another great source is youtube for car repairs just do a search in Google to see what comes up. Good luck
 
  #3  
Old 07-15-2018, 07:31 AM
Thread Starter
Join Date: May 2017
Posts: 4
Default

This whole thing started weeks ago with a rapid blink. I checked rear bulbs and they were the wrong #, so I put in the correct bulbs. all good. two weeks rapid blink, front bulb a little loose, all good. one week daylights and turnsignals dead. checked fuses, one fuse for turnsignal (15 amp) reads -.001. replaced it with a new one and reads the same but everything works for now. go figure.
 
  #4  
Old 07-15-2018, 07:32 AM
Thread Starter
Join Date: May 2017
Posts: 4
Default

Thank you for your help
 

Thread Tools
Search this Thread
Advertising
Featured Sponsors
Vendor Directory

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.