New Member Area New to Monte Carlo Forum? Stop in tell us about you.

2007 Monte Carlo starting issues

  #1  
Old 02-24-2019, 03:16 PM
Thread Starter
Join Date: Feb 2019
Posts: 1
Default 2007 Monte Carlo starting issues

Hello, I have a 2007 Monte Carlo 3.5 l LT with multiple issues. First the car would not start or crank. I changed all of the passlock devices. Such as the key cylinder, cylinder housing, and the two passlock devices that mount to the cylinder housing. Once that was installed I did the key relearn procedure 10 min with the key in the on position 10 seconds in the off position. I did that 3 times. Still no crank or start. I did that procedure numerous times with no results. Next I reinstalled the passlock key identifier the unit that slides over the key cylinder. Then tried to start and it fired right up. At that point the dash gauges started going wacky. The center of the dash would read theft deterent malfunction, brake system faliure, then the ABS light was on with the security light. The I turned the key to the off position and then tried to restart it and the car would not start. So I waited a while and tried to start it again and it fired up. But it was running like it was starving for fuel. So I read several complaints and they fixed there car with the Newrockies passlock fix module. I bought the module and now it fires up every time and drives nice except it shifts hard in to gear, it still has the theft deter ant message along with the ABS LIGHT and the brake assist message on. Does any one have any ides ?
 

Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.