Opinion Needed: How do I fix or reset 07 MC anti theft system - Monte Carlo Forum - Monte Carlo Enthusiast Forums

Go Back  Monte Carlo Forum - Monte Carlo Enthusiast Forums > General Forums > General Monte Carlo Talk
Reload this Page >

Opinion Needed: How do I fix or reset 07 MC anti theft system

General Monte Carlo Talk Talk about the Monte Carlo. Does not have to be your Monte. Can include pics and games.

Opinion Needed: How do I fix or reset 07 MC anti theft system

  #1  
Old 10-26-2017, 04:43 PM
Thread Starter
Join Date: Oct 2017
Posts: 1
Default How do I fix or reset 07 MC anti theft system

I had trouble with the shifter going in & out of gears because of the button under the console..I got that problem fixed permanently & after that the anti theft light comes on & the car says nothing at all when I try to crank. Lights & everything work but it want start. Tried unhooking the battery but that didn't work I really don't want to keep messing with it or take it to an expensive mechanic because i know theres a way to bypass the problem. I've been reading the forums watching YouTube videos & nothing works idk if it's the difference in the yrs of the car but I NEED HELP..please!!
 
  #2  
Old 10-27-2017, 08:53 AM
Monte Of The Month -- November 2016
3 Year Member
3 Year Member1 Year Member
Join Date: May 2013
Location: NC
Posts: 268
Default

Are you using the correct key? The reason I ask is I also had a sort of similar issue.
First off I own two 2006 monte carlos, 1 is an 06 SS and also an 06 LT. Anyhow a few weeks back I hopped into the LT in a hurry, and went to start up and nothing, just a slight click if anything. Didn't have time to fiddle fart around and took the 14 Malibu instead.
Anyhow next day I went to investigate and noticed I had tried to use the key from my SS to start the LT. I put the LT key in and it started up and drove fine but I had the service theft deterrent system message pop up on the info center.
So I had to actually relearn the theft system by doing the 30 minute relearn cycle for both keys for the LT. I had to take the key, turn to the on position(do not try to start car) the security light will come on and stay lit. Leave the key in the on position for about 10 minutes the security light will go off. Then turn the key back to the off position for 5 seconds. And turn it back to the on position again, the security light comes back on and wait another 10 min until the light goes back off and turn the key back to off.
Again wait 5 seconds with key in off position and then turn back to the on position for one last time for 10 min, the light goes back out and the vehicle should start up and that relearns the theft system.
one tid bit of advice, hook up a battery charger while doing this because it will all but kill the battery.

If that doesn't work for you I would ask, did this issue develop as soon and the repair to the shift interlock was repaired?
I know the wire breaks for the solenoid down by the shifter is common. Can you confirm the car is actually in park when trying to start? Have you tried putting the car in neutral and see if it will start? If for some reason the car thinks it not in park or neutral it can give a similar symptom.
Or perhaps if that broken harness was repaired, recheck the connections.
 

Last edited by Aerocoupe86; 10-27-2017 at 09:03 AM.
  #3  
Old 10-27-2017, 03:31 PM
Join Date: May 2016
Posts: 57
Default

I just did the 30 min. relearn after installing new ignition switch and lock cylinder due to the security light and no start. it worked, surprised me, I was thinking what do I do if it does not work. do exactly as Aerocoup86 says.
 
  #4  
Old 12-18-2018, 02:33 AM
Join Date: Dec 2018
Posts: 2
Default

Originally Posted by Aerocoupe86 View Post
Are you using the correct key? The reason I ask is I also had a sort of similar issue.
First off I own two 2006 monte carlos, 1 is an 06 SS and also an 06 LT. Anyhow a few weeks back I hopped into the LT in a hurry, and went to start up and nothing, just a slight click if anything. Didn't have time to fiddle fart around and took the 14 Malibu instead.
Anyhow next day I went to investigate and noticed I had tried to use the key from my SS to start the LT. I put the LT key in and it started up and drove fine but I had the service theft deterrent system message pop up on the info center.
So I had to actually relearn the theft system by doing the 30 minute relearn cycle for both keys for the LT. I had to take the key, turn to the on position(do not try to start car) the security light will come on and stay lit. Leave the key in the on position for about 10 minutes the security light will go off. Then turn the key back to the off position for 5 seconds. And turn it back to the on position again, the security light comes back on and wait another 10 min until the light goes back off and turn the key back to off.
Again wait 5 seconds with key in off position and then turn back to the on position for one last time for 10 min, the light goes back out and the vehicle should start up and that relearns the theft system.
one tid bit of advice, hook up a battery charger while doing this because it will all but kill the battery.

If that doesn't work for you I would ask, did this issue develop as soon and the repair to the shift interlock was repaired?
I know the wire breaks for the solenoid down by the shifter is common. Can you confirm the car is actually in park when trying to start? Have you tried putting the car in neutral and see if it will start? If for some reason the car thinks it not in park or neutral it can give a similar symptom.
Or perhaps if that broken harness was repaired, recheck the connections.
I'm having the same problem my car security light is on but not blinking no start or crank lights come on and when I turn the key forward it won't go in neutral no chime and if I lock doors outside of the car it won't unlock like supposed to which both sides unlock need help asap just brought 3 days ago
 

Thread Tools
Search this Thread
Advertising
Featured Sponsors
Vendor Directory

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

© 2018 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.