6th Gen ('00-'05): Sometimes dim gear selector lights on cluster - Monte Carlo Forum - Monte Carlo Enthusiast Forums


Monte Carlo Repair Help Have a Monte problem and need help? Good at troubleshooting? Discuss it here!

Reply
 
 
 
Thread Tools Search this Thread
  #1  
Old 04-14-2013, 12:37 PM
Thread Starter
 
Join Date: Jan 2013
Location: Lilly pa
Posts: 4
Exclamation Sometimes dim gear selector lights on cluster

Ok here's my problem. The gear selector lights on the instrument cluster where the mileage is, they are dim during the day and slightly visible at night. Now other times they are completely visible with no problems. Would this be bad bulbs or the dimmer switch?
Reply With Quote
  #2  
Old 04-14-2013, 12:45 PM
lilmonteZ34's Avatar
1 Year Member
 
Join Date: Feb 2013
Posts: 94
Default

Experiment with the dimmer switch. If it dims again, manually turn the dimmer to the brightest setting.
Reply With Quote
  #3  
Old 04-14-2013, 01:09 PM
nyislanders's Avatar
5 Year Member1 Year Member
 
Join Date: Feb 2010
Location: Long Island, NY
Posts: 351
Default

I have that too, it's probably a loose connection somewhere. Honestly, I fixed it by hitting the cluster lightly a few times and it comes back to full brightness. :P
Reply With Quote
  #4  
Old 07-06-2015, 01:05 PM
1 Year Member
 
Join Date: Jun 2013
Location: Mexicali, Baja California, Mexico
Posts: 37
Default Same issue

Hi,

I know this threat is a little old but I am having this same issue with my 01 SS, the "PRND321" LCD display gets dim and after a little hit comes back. But now the full cluster lighting works random. Whenever I hit the lens the LCD will come up to full brightness but the tach lights go off. Some other times everything works except the tach and some other times everything works as it should. Any suggestions?

Note, I previously removed the cluster 2 months ago to replace the cluster lens because I broke it when hitting the lens to make the LCD bright up but everything was working perfectly, I just started noticing this intermittent failure about 2 weeks ago.
Reply With Quote
  #5  
Old 07-06-2015, 01:26 PM
P343's Avatar

Monte of the Month -- February 2015
Monte Of The Month -- April 2017
3 Year Member
1 Year Member
iTrader: (1)
 
Join Date: Feb 2014
Location: Albany, Indiana
Posts: 6,949
Default

It almost sounds like something may be loose. I would go back and recheck your connections
Reply With Quote
  #6  
Old 07-06-2015, 03:23 PM
1 Year Member
 
Join Date: Jun 2013
Location: Mexicali, Baja California, Mexico
Posts: 37
Default

I will give it a try to the connectors later today, hope this fix it.

Thanks!
Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Dim odometer and gear position indicator el pachuco Monte Carlo Repair Help 6 02-21-2015 09:11 PM
6th Gen ('00-'05): gear set, 4th gear hub, channel plate gouged! help! turbo monte Engine/Transmission/Performance Adders 2 04-04-2013 10:01 AM
Transmission gear selector broken? SilverRiff Interior/Audio/Visual Electronics 0 06-29-2010 07:21 PM
lights and heater dim when ideling?? Yellow_Monte General Monte Carlo Talk 9 02-14-2008 09:28 AM
87-88 monte LS gear selector? erik2282 General Monte Carlo Talk 1 10-01-2005 03:15 PM


Tags
05, carlo, cluster, dimming, gear, instrument, lights, monte, selector, working

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Advertising
Featured Sponsors
Vendor Directory

All times are GMT -5. The time now is 11:28 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.