MCF Website Problems & Issues This area is for problems or suggestions relating specifically to the MCF site, not the car.

Driver Information Center / Dash Cluster Problems

  #1  
Old 07-10-2019, 01:18 PM
Thread Starter
Join Date: Mar 2019
Location: CA
Posts: 8
Default Driver Information Center / Dash Cluster Problems

Good day all,

Please forgive the long story, but I want to give all of the info. I recently purchased an '07 SS, the key would't release, due to a dead battery. Charged the battery, started it and the car would not shut off without bumping the key back and forth, several times. My mechanic fixed the problem. I bought a new shifter, after it wouldn't shift out of park, after the initial problem was fixed.

I was having a problem with my dash cluster. The indicator box is missing from PRND, so the car doesn't know that it's in park and won't give me the option to program my key fob in the Driver Information Center, it also won't display oil pressure. I also have no speedometer, all other gauges work, and I think I have all the other options in my Driver Info Center.

My wife has misplaced my scan tool, so I had a guy come buy to scan and possible flash the TCM, BCM or ECM, still learning how the modules and CAN Bus stuff works. He told me I needed a new TCM, so I bought one that was supposedly already flashed. It was installed, but I still have the same problem. My aftermarket Kenwood is hooked to the OBD II censor, and is capable of displaying all of the vehicle info, but it won't display the speed for some reason, also, it's not seeing any codes. PLEASE HELP. Thank you.

 

Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.