Interior/Audio/Visual Electronics Discuss your audio/visual system and your interior here.

Will it work? Epoxy and Sub

  #1  
Old 06-29-2011, 05:38 PM
Franks 03SS's Avatar

Monte Of The Month -- September 2011
2011 Monte Of The Year
3 Year Member1 Year Member
Thread Starter
Join Date: May 2011
Location: Lakeland FL
Posts: 4,006
Default Will it work? Epoxy and Sub

Have a quick a question for u guys, I have a 15 inch solo baric laying around, it works and all but the "adhesive" around the edge where the cone and frame meet has lifted so the cone is no longer attached to the frame lol
I was wondering if I could use some epoxy along the edge to stick it back together
I already have one in the Monte and would like to have both of em in
 
  #2  
Old 06-29-2011, 06:01 PM
Taz's Avatar
Taz
Taz is offline

Monte Of The Month -- March 2014
10 Year Member
5 Year Member3 Year Member1 Year Member
Join Date: Aug 2007
Location: Windsor
Posts: 18,620
Default

I moved your thread into the audio section. Hoefull you'll get a quicker response.
 
  #3  
Old 06-29-2011, 06:14 PM
Franks 03SS's Avatar

Monte Of The Month -- September 2011
2011 Monte Of The Year
3 Year Member1 Year Member
Thread Starter
Join Date: May 2011
Location: Lakeland FL
Posts: 4,006
Default

Originally Posted by Taz View Post
I moved your thread into the audio section. Hoefull you'll get a quicker response.
Thanks taz
 
  #4  
Old 06-29-2011, 06:17 PM
red04montels's Avatar
Monte Of The Month -- September 2010
5 Year Member
3 Year Member1 Year Member
Join Date: Aug 2009
Location: Wisconsin
Posts: 9,356
Default

so the rubber surrounding is the part that has came off? make sure the epoxy will be okay on the rubber and if that's the case i'd say it would be fine
 
  #5  
Old 06-29-2011, 08:03 PM
Join Date: Dec 2010
Posts: 697
Default

use a crap ton of clamps around the edge you want 100% contact! 100%!!!!!!!!!!!
 
  #6  
Old 06-29-2011, 11:06 PM
Franks 03SS's Avatar

Monte Of The Month -- September 2011
2011 Monte Of The Year
3 Year Member1 Year Member
Thread Starter
Join Date: May 2011
Location: Lakeland FL
Posts: 4,006
Default

Originally Posted by trewyn15 View Post
so the rubber surrounding is the part that has came off? make sure the epoxy will be okay on the rubber and if that's the case i'd say it would be fine
Yes it's the "cone" I guess you could say, just all around the edge it has lifted
I don't really know how to describe it lol

Originally Posted by walkingonabullet View Post
use a crap ton of clamps around the edge you want 100% contact! 100%!!!!!!!!!!!
I will have to go buy some and give it a try then
Thanks Guys
 
  #7  
Old 06-30-2011, 01:57 PM
Join Date: Oct 2010
Posts: 654
Default

Originally Posted by 03limitedss View Post
Have a quick a question for u guys, I have a 15 inch solo baric laying around, it works and all but the "adhesive" around the edge where the cone and frame meet has lifted so the cone is no longer attached to the frame lol
I was wondering if I could use some epoxy along the edge to stick it back together
I already have one in the Monte and would like to have both of em in
It could work, for a little while at least. The best thing to use would be IC 2000, so long as your surround isn't foam

Cyanoacrylate Glue
 
  #8  
Old 06-30-2011, 02:07 PM
Franks 03SS's Avatar

Monte Of The Month -- September 2011
2011 Monte Of The Year
3 Year Member1 Year Member
Thread Starter
Join Date: May 2011
Location: Lakeland FL
Posts: 4,006
Default

Originally Posted by Milhouse View Post
It could work, for a little while at least. The best thing to use would be IC 2000, so long as your surround isn't foam

Cyanoacrylate Glue
im goin to try some Devcon 5 Minute Epoxy like this guy ..... >>> YouTube - ‪Pt. 2 Repairing Subwoofer Surrounds / Fixing Soundstream XXX 18" Subs Tutorial - How To Fix & Repair‬‏
and im pretty sure it'll hold up if not then oh well lol its an OLD sub anyways :p
 
  #9  
Old 06-30-2011, 02:34 PM
lougreen03's Avatar

Monte Of The Month -- March 2013
5 Year Member3 Year Member1 Year Member
Join Date: Jun 2010
Location: michigan
Posts: 8,442
Default

I think it will work just fine.
 
  #10  
Old 06-30-2011, 02:39 PM
Franks 03SS's Avatar

Monte Of The Month -- September 2011
2011 Monte Of The Year
3 Year Member1 Year Member
Thread Starter
Join Date: May 2011
Location: Lakeland FL
Posts: 4,006
Default

Originally Posted by lougreen03 View Post
I think it will work just fine.
thanks lou
i'll get to it monday though when i have plenty of spare time
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Project Monte 04
Interior/Audio/Visual Electronics
3
03-15-2011 07:40 PM
s_dot03
Interior/Audio/Visual Electronics
3
05-26-2010 09:27 AM
jaws2008
Interior/Audio/Visual Electronics
8
04-27-2009 12:09 AM


Thread Tools
Search this Thread
Quick Reply: Will it work? Epoxy and Sub


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.