Interior/Audio/Visual Electronics Discuss your audio/visual system and your interior here.

rear defroster

  #1  
Old 01-12-2012, 07:35 PM
3 Year Member1 Year Member
Thread Starter
Join Date: Dec 2011
Posts: 168
Default rear defroster

I am going to give this one more try and then of to the dreaded dealer.

Here goes everytime you turn on the rear defroster the radio get static and you can't listen to it unless you shut of the defroster how come
 
  #2  
Old 01-12-2012, 08:57 PM
lougreen03's Avatar

Monte Of The Month -- March 2013
5 Year Member3 Year Member1 Year Member
Join Date: Jun 2010
Location: michigan
Posts: 8,442
Default

Maybe there is a short where the defroster plug wires go and it's shorting on the body. I would inspect the wires around the rear windows for cracks or breaks in the insulation. Just a thought.
 
  #3  
Old 01-12-2012, 11:39 PM
Join Date: Sep 2010
Location: Hopewell, PA
Posts: 2,378
Default

Originally Posted by lougreen03 View Post
Maybe there is a short where the defroster plug wires go and it's shorting on the body. I would inspect the wires around the rear windows for cracks or breaks in the insulation. Just a thought.
That could be, when you consider the rear defroster doubles as the the radio antenna.
 
  #4  
Old 01-13-2012, 07:24 AM
03SSLE's Avatar
Monte Of The Month -- August 2012
5 Year Member3 Year Member1 Year Member
Join Date: Apr 2011
Location: Seattle
Posts: 6,074
Default

It's possible that you have a bad/loose contact somewhere in the circuit. Check the connectors that slide onto the tab at the rear window. Make sure they are clean and tight. It could also be dirty or worn switch contacts. Installing a 0.1 uF ceramic capacitor on the lead that goes to the defroster will help eliminate any ripple that may be present. The + side of the cap goes to the switch and the - side goes to ground.
 
  #5  
Old 01-13-2012, 10:13 PM
3 Year Member1 Year Member
Thread Starter
Join Date: Dec 2011
Posts: 168
Default

Thank you to all of you that helped will check in the morning once again thank you
 
  #6  
Old 01-13-2012, 11:11 PM
The_Maniac's Avatar

Monte Of The Month -- December 2011
Monte Of The Month -- September 2014
5 Year Member
3 Year Member1 Year Member
iTrader: (2)
Join Date: Apr 2010
Location: Mentor, Ohio
Posts: 10,955
Default

there is a module behind one of the rear quarter interior panels. it handles the defroster and antenna. My guess, it's bad. There are two different part numbers for it and I think roughly $20 a piece from the dealer. I was looking into that when my defroster stopped working and now I think it's a failed circuit breaker.

If you are comfortable taking the interior trim apart, I'd say get the module out, head to the dealer with it and swap it. I want to say it's on the passenger side.

Hope that helps.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
rjmfa
Monte Carlo Repair Help
10
12-22-2012 12:17 AM
MJClemm
Monte Carlo Repair Help
24
10-16-2012 06:16 PM
SSDriver8
Monte Carlo Repair Help
9
06-13-2010 08:25 PM
davesbedroom
Monte Carlo Repair Help
11
01-07-2007 11:45 AM
01pacecar
Monte Carlo Repair Help
1
04-29-2006 12:38 PM


Thread Tools
Search this Thread
Quick Reply: rear defroster


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.