General Monte Carlo Talk Talk about the Monte Carlo. Does not have to be your Monte. Can include pics and games.

Turn signal and flashers not working

  #1  
Old 06-05-2018, 02:04 PM
Thread Starter
Join Date: Jun 2018
Posts: 7
Default Turn signal and flashers not working

Have a quick question. Just purchased an 04 Monte Carlo SS and turn signals and hazards don t' work. If it was the handle switch on column that controls turn signals and wipers, then nothing would work. Is it the hazard switch on the dash?
 
  #2  
Old 06-05-2018, 02:14 PM
ChibiBlackSheep's Avatar

Monte Of The Month -- August 2014
10 Year Member
5 Year Member3 Year Member1 Year Member
Join Date: Sep 2008
Location: Wyncote, PA
Posts: 24,822
Default

Most likely yes, it's the hazard switch.
 
  #3  
Old 06-06-2018, 01:48 AM
ZIPPY02's Avatar
Monte Of The Month -- May 2012
Monte Of The Year 2012
Monte Of The Month -- February 2017
10 Year Member
5 Year Member3 Year Member1 Year Member
Join Date: Jan 2008
Location: Mountains of Utah
Posts: 4,653
Default

Similar problems in my GMC truck. Drove for 2 weeks with no signals of hazards, luckily the brake lights still worked. Replaced the whole turn signal hazard assembly. Same thing, ended up being a flasher unit that plugs into a box by the drivers feet. Apparently my long *** clown feet knocked it partially out. Fully reseated it and well what do you know, turns and hazards again, now everybody loves me again...
 
  #4  
Old 03-30-2019, 03:57 AM
Joe
Joe is offline
Join Date: Mar 2019
Posts: 3
Default

did you find out what it was mine is similiar 2003 MC buzzing sound directionals
 

Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.