General Monte Carlo Talk Talk about the Monte Carlo. Does not have to be your Monte. Can include pics and games.

Battery light

  #1  
Old 11-09-2018, 03:43 PM
Thread Starter
Join Date: May 2018
Posts: 22
Default Battery light

help battery light stays on!!!

My battery is new and new starter and had alternator checked ( I removed it and restall it) and light is still on why is that?
 
  #2  
Old 11-09-2018, 04:59 PM
drivernumber3's Avatar
Monte Of The Month -- May 2015
Monte Of The Month -- March 2017
5 Year Member
3 Year Member1 Year Member
Join Date: May 2013
Location: Nebraska
Posts: 4,208
Smile

Originally Posted by Shawna Sanchez View Post
help battery light stays on!!!

My battery is new and new starter and had alternator checked ( I removed it and restall it) and light is still on why is that?
There is a possibility that the battery cables are no longer good, or the Ground is bad also. So check those cables to see. Battery would show 14 plus volts when charged if not that could be the problem sometimes they are bad out of the box.
Also I am attaching a google link that has symptoms listed such as you have and maybe the fix is right there. you may find it.

https://www.google.com/search?source...60.dEXWkl2wHMQ
 
  #3  
Old 11-09-2018, 05:14 PM
Thread Starter
Join Date: May 2018
Posts: 22
Default

How would I check the battery post connection to see if they are faulty? And where is the ground wire?
 
  #4  
Old 11-09-2018, 10:13 PM
drivernumber3's Avatar
Monte Of The Month -- May 2015
Monte Of The Month -- March 2017
5 Year Member
3 Year Member1 Year Member
Join Date: May 2013
Location: Nebraska
Posts: 4,208
Smile

Originally Posted by Shawna Sanchez View Post
How would I check the battery post connection to see if they are faulty? And where is the ground wire?
You need to get to the Battery they are usually covered up in these cars, mine is.
I have a side terminal battery.
I just replaced mine this summer.
The old one was still functional but I knew is was probably close. The battery Case had a bulge in it after I got it out.
I removed all the things blocking it ( windshield washer reservoir, engine bay cross member, probably the Air Cleaner too) etc.
Not sure of what year your car is. But most likely it is on the drivers side of the Car. Might be a Red small box above it for Jump starting the car too.
Check and clean the cables where they attach to the battery they make a metal brush for this work, remove the cables and clean each one.
Put the Red one back on first then the Black which is the ground cable.
Check those cables to make sure there are no cracks in them and at the end of the black one it should ground to the frame some place. Probably with a bolt attached. clean that as well. use the metal brush. Make sure that connection is tight. A friend of mine uses a little dremel tool, you can do it with a cordless drill also. Inspect the cables with a flash light to make sure they aren't cracked. If they are they are junk.
If the battery is 3 or more years old it will be weak anyway and may cause the light issue too.
 
  #5  
Old 11-09-2018, 10:19 PM
Thread Starter
Join Date: May 2018
Posts: 22
Default

My battery is no older than a month old so this is unexplainable. Itís a 2005 Monte Carlo with side post and all cables look good. alternator I was told was good (almost like new he said) so this is all confusing to me.. Having someone coming tomorrow to test the battery as it might be faulty.
 
  #6  
Old 11-10-2018, 08:18 AM
drivernumber3's Avatar
Monte Of The Month -- May 2015
Monte Of The Month -- March 2017
5 Year Member
3 Year Member1 Year Member
Join Date: May 2013
Location: Nebraska
Posts: 4,208
Question Tracking the stuff down can be a pain.

Originally Posted by Shawna Sanchez View Post
My battery is no older than a month old so this is unexplainable. Itís a 2005 Monte Carlo with side post and all cables look good. alternator I was told was good (almost like new he said) so this is all confusing to me.. Having someone coming tomorrow to test the battery as it might be faulty.
Well these are the easy and cheap fixes. If it isn't that! Then you are looking at the Computer controls of the car. If you had a chance to review any of the google links I provided that is what they are indicating. So I am hoping this will not be the case. Tracking the stuff down can be a pain.
 
  #7  
Old 11-26-2018, 05:10 AM
Join Date: Nov 2018
Posts: 2
Default

Did you ever get any resolution on this? Im having similar issues on my wife's Caddy, and all the cables have been checked and cleared, along with the alternator.
 
  #8  
Old 11-26-2018, 07:43 AM
Thread Starter
Join Date: May 2018
Posts: 22
Default

Originally Posted by Hurricane87 View Post
Did you ever get any resolution on this? Im having similar issues on my wife's Caddy, and all the cables have been checked and cleared, along with the alternator.

Yes I did.. when I reinstalled my starter the large bolt was not in tight enough which was throwing the alternator which would not charge the battery... Hope you find out your problem. And itís an easy fix like mine was
 

Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.