Engine/Transmission/Performance Adders Chat about your engine, transmission, nitrous, superchargers, turbos, and tuning.
Sponsored by:
Sponsored by:

Transmission or EVAP problem?

  #1  
Old 12-13-2016, 01:42 PM
S.O.G.'s Avatar
5 Year Member
3 Year Member1 Year Member
Thread Starter
Join Date: Mar 2012
Location: Minnesota
Posts: 513
Question Transmission or EVAP problem?

Ok so about a week ago I felt my transmission slip for the first time. Was going up a small hill and my RPMs went up but my car took a while before it jerked itself forward. I immediately took it to get the transmission flushed and 2 days later it got worse. Now the car is jerking around all the time...only in 3rd gear. My car shifts into all gears just fine but when it settles in 3rd and I'm cruising it'll begin to jerk around, as if it's trying pretty hard to move forward. Somewhat of a dying car feeling...anyway yesterday I got a code p0496. Scanned at oreilly and it was the evap purge solenoid, which I replaced in spring not long ago...is this symptom my car is having a transmission issue or evap??
 
  #2  
Old 12-13-2016, 02:21 PM
ChibiBlackSheep's Avatar

Monte Of The Month -- August 2014
10 Year Member
5 Year Member3 Year Member1 Year Member
Join Date: Sep 2008
Location: Wyncote, PA
Posts: 24,822
Default

Your issue sounds more like the converter locking up and not releasing well.

Could just need to get that solenoid replaced.

Are you driving with the car in D, or in 3? If you are driving around in D and this is happening, try to drive around in 3 and see if it stops. I believe 3 prevents the converter from locking up in 3rd gear.
 
  #3  
Old 12-13-2016, 03:45 PM
S.O.G.'s Avatar
5 Year Member
3 Year Member1 Year Member
Thread Starter
Join Date: Mar 2012
Location: Minnesota
Posts: 513
Default

I always drive it in 3. So idk if that's what it could be?
 
  #4  
Old 12-14-2016, 01:26 AM
Join Date: Dec 2007
Posts: 1,295
Default

Even if the CEL is OFF, ... Read your Codes again.

Check for ENG Codes which don't make the CEL come on.

My EVAP System was completely overhauled.
New EVAP everything!

No CEL Light!

(2) OBD2 ENG Codes still exist.

1). P1811 -- Your tranny is about to **** bed!

2). PO521 -- Your Oil Pressure Sensor ain't cuttin' it.
 
  #5  
Old 12-14-2016, 07:21 AM
S.O.G.'s Avatar
5 Year Member
3 Year Member1 Year Member
Thread Starter
Join Date: Mar 2012
Location: Minnesota
Posts: 513
Default

Originally Posted by RickCoMatic View Post
Even if the CEL is OFF, ... Read your Codes again.

Check for ENG Codes which don't make the CEL come on.

My EVAP System was completely overhauled.
New EVAP everything!

No CEL Light!

(2) OBD2 ENG Codes still exist.

1). P1811 -- Your tranny is about to **** bed!

2). PO521 -- Your Oil Pressure Sensor ain't cuttin' it.

CEL light is on. It's giving me evap code. But would this cause my car to act in the way it's acting?
 
  #6  
Old 01-03-2017, 06:24 PM
Join Date: Jan 2017
Posts: 4
Default

My trans doesnt work at all. I just found the evap lin to be be melted. Would the evap system stop the car fro m mmoving
 
  #7  
Old 08-16-2018, 03:40 PM
Join Date: Aug 2018
Posts: 1
Default Evap and Transmission failure

3months ago, i was driving on an interstate road and my car came to a full stop, on my dash board screen came transmission failed. I panicked and after about 3minutes it drove normally and the message disappeared from my screen.
i have been doing oil change and serviced my car every month until last month when i got a check engine light. The car started acting funny,it would drive properly then allover a sudden stop, I went to autozone and was told i had 2codes P0456 which is the Evap purge control valve and P26B7 (they didnt know what that was).
Replaced the Evap but the code still comes up and my car is getting worse.
what do you think is the problem with my ford escape?
 
  #8  
Old 01-18-2019, 04:42 PM
Join Date: Jan 2019
Posts: 1
Default

Originally Posted by Remour Yah View Post
3months ago, i was driving on an interstate road and my car came to a full stop, on my dash board screen came transmission failed. I panicked and after about 3minutes it drove normally and the message disappeared from my screen.
i have been doing oil change and serviced my car every month until last month when i got a check engine light. The car started acting funny,it would drive properly then allover a sudden stop, I went to autozone and was told i had 2codes P0456 which is the Evap purge control valve and P26B7 (they didnt know what that was).
Replaced the Evap but the code still comes up and my car is getting worse.
what do you think is the problem with my ford escape?
Hey, I'm having the same exact problem with my Ford Focus. Did you get your car fixed??
 
  #9  
Old 02-21-2019, 12:29 AM
Join Date: May 2013
Location: Jacksonville,Florida
Posts: 332
Default

could the cat be clogged? my 03 3.8 jerked and wouldn't go, accelerate and would die and it was my cat converter ?
 

Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.