Monte Carlo Forums

Go Back   Monte Carlo Forum - Monte Carlo Enthusiast Forums > Your Ride > Engine/Transmission/Performance Adders
Sign in using an external account
Register Forgot Password?
Search


Welcome to the Monte Carlo Forum - Monte Carlo Enthusiast Forums.
If this is your first visit, be sure to check out the FAQ by clicking the link above. You may have to register before you can post: click the register link above to proceed. To start viewing messages, select the forum that you want to visit from the selection below.

Reply
 
 
 
 
LinkBack Thread Tools Search this Thread
  #1  
Old 03-18-2010, 08:22 AM
 
Trader Rating:(0)
Join Date: Mar 2010
Posts: 6
Unhappy How to replace a fuel pump on a 00' monte carlo ss

hi.

i have a 2000 monte carlo SS and need to replace the fuel pump through behind the back seat.... can anyone please give me any instruction on how to go about doing this? also on how to replace the fuel filter and location?

thank you.
Reply With Quote
  #2  
Old 03-21-2010, 06:50 PM
 
Trader Rating:(0)
Join Date: Mar 2008
Posts: 162
Default

The fuel filter is located on the drivers side on the rear chassis rail forward of the tire
The fuel pump is located in the fuel tank, remove the trunk floor carpet, then the fuel pump access panel, the fuel pump retainer ring can be accessed through the panel, clean the area before removing the pump and sender assembly, replace the "o" ring seal when replacing the assembly, the pump and sender assembly will spring up when the retainer ring is removed
Reply With Quote
  #3  
Old 03-22-2010, 11:26 AM
 
Trader Rating:(0)
Join Date: Mar 2010
Posts: 6
Default

ok,
i replaced the fuel pump, but now for some reason my gas gauge is reading crazy, its always on either empty or full, and sometimes it moves around, did i do something wrong?????
Reply With Quote
  #4  
Old 03-22-2010, 09:53 PM
 
Trader Rating:(0)
Join Date: Mar 2008
Posts: 162
Default

possibly got the float hung up on something or bad connection at the assembly connector? Did you replace the whole assembly or just the pump? Check for proper ground at the assembly (the whole thing works on a variable resistor to ground)

Last edited by montes my python; 03-23-2010 at 12:03 AM.
Reply With Quote
  #5  
Old 03-22-2010, 10:29 PM
 
Trader Rating:(0)
Join Date: Mar 2010
Posts: 26
Default

Most likely a dirty ground.
Reply With Quote
Old 03-22-2010, 10:29 PM
 
 
 
Reply

Tags
2000, back, bad, carlo, change, filter, fuel, long, monte, pump, removal, repacement, replace, seat, ss


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Advertising

Featured Sponsors
Vendor Directory
Our Sponsors

All times are GMT -5. The time now is 03:35 AM.

Internet Brands, Inc.



SEO by vBSEO ©2010, Crawlability, Inc.