Monte Carlo Repair Help Have a Monte problem and need help? Good at troubleshooting? Discuss it here!

6th Gen ('00-'05): Shuddering engine

  #1  
Old 04-10-2019, 03:27 PM
Thread Starter
Join Date: Apr 2019
Location: Alabama
Posts: 2
Default Shuddering engine

I'm curious I have a 2000 3.4l monte it drives fine when I first start it up but after its good and warm if I accelerate the front end shudders bad and that's going straight on the road not turning ive already replaced hub assembly and rear struts any ideas
 
  #2  
Old 04-14-2019, 11:41 PM
Join Date: Feb 2019
Posts: 36
Default

When is the last time you have checked your transmission fluid level? When was the last time you changed the transmission fluid. Once its viscosity is worn out the transmissions torque converter will shudder under acceleration. Not saying this is your problem, but something to ponder. There is a product to add to your transmission fluid called "Shudder Guard". It is cheap but will work for a few hundred miles. If the shuddering stops then you know there is a transmission repair in your near future.

https://www.wynnsusa.com/product/shudderguard/

If you’re searching for “What is torque converter shudder?“, you’ve likely experienced an issue when you’re driving around 45MPH and you get a sudden shudder in the vehicle. It is similar to running over a rough spot on the road or over a cattle guard. Just as quick as it happened, it is gone until it happens again. Read more about torque converter shudder in this post.

Torque Converter Shudder & Diagnosis

There are a lot of people who describe this as hitting a rough spot in the road. Often times the problem is a torque converter shudder. The torque converter shudder is a brief shake in the vehicle whenever the internal clutches apply inside of the torque converter. They call this a lock up. Often this issue is misdiagnosed and sometimes will end up with the transmission needing to be rebuilt.
 
  #3  
Old 04-14-2019, 11:49 PM
Thread Starter
Join Date: Apr 2019
Location: Alabama
Posts: 2
Default

I actually have not changed it in awhile the security system locked up on me right after I got it and it sat for 8 months so I've actually only been driving it again for about 6 months I'll try that though thank you
 

Thread Tools
Search this Thread
Advertising
Featured Sponsors
Vendor Directory

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.