Monte Carlo Repair Help Have a Monte problem and need help? Good at troubleshooting? Discuss it here!

7th Gen ('06-'07): Popping sound from steering

  #1  
Old 04-04-2019, 08:58 AM
Thread Starter
Join Date: Aug 2014
Location: Missouri
Posts: 2
Default Popping sound from steering

Hi everyone, This is my first post on this forum. So I need a little help with my 2006 Monte Carlo SS, When under power and starting from a dead stop and making a turn ( more on a Left than on a Right turn) there is a popping sound coming from the front end. Once you make the turn and go back to driving straight the popping stops. There is no sound once I am up to speed and making any turns under normal driving. I have had the stabilizer bar and bushings replaced by our local Chevy dealer but the popping sound still remains. Any help in solving this problem will be greatly appreciated.
 
  #2  
Old 04-04-2019, 09:12 AM
ChibiBlackSheep's Avatar

Monte Of The Month -- August 2014
10 Year Member
5 Year Member3 Year Member1 Year Member
Join Date: Sep 2008
Location: Wyncote, PA
Posts: 24,820
Default

Wheel hub assemblies are very common to go bad on these cars.

Do you FEEL the popping in your wheel? Sometimes you need to spray some white lithium grease into the intermediate steering shaft knuckle right above the pedals.
 
  #3  
Old 04-04-2019, 09:40 AM
Thread Starter
Join Date: Aug 2014
Location: Missouri
Posts: 2
Default

There is no feedback through the steering wheel. Just can hear the noise.
 

Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.