A few troubles, Signals, Power Window, Steering. - Monte Carlo Forum - Monte Carlo Enthusiast Forums


Monte Carlo Repair Help Have a Monte problem and need help? Good at troubleshooting? Discuss it here!

Reply
 
 
 
Thread Tools Search this Thread
  #1  
Old 09-23-2008, 07:25 AM
Thread Starter
 
Join Date: Jan 2007
Posts: 24
Default A few troubles, Signals, Power Window, Steering.


A few problems I have been having with my 2001 Monte Carlo SS, Quite Basic I Suppose, but just haven’t looked into them.


The Driver’s side window goes down fine, but when trying to put it up it is slow, and has gotten slower recently, is their a fuse or something to replace to fix this problem?[/ol]


My turn signals, they are very temperamental, sometimes they work sometimes they don’t, is this another fuse issue or a loose connection? It’s very weird I’ll just be driving or just turn on the car and they won’t work, 10 minutes later or when I start my car back up they will be working, one of the weirdest things I have ever seen.[/ol]


The Driver and Passenger climate control lights are out, is this a easy fix, buy the bulbs, and then take off the whole panel?[/ol]


The one big issue is normally only when I first start up the car after sitting for a while. Turning it feels like something is rubbing and then when I hit the gas and go straight there is like a whining noice. Very weird. After a while it goes away, but still making strong turns you can here the rubbing and whining type noice. Any one ever experience this?[/ol]

Many Thanks for any advice.
Reply With Quote
  #2  
Old 09-23-2008, 01:11 PM
ChibiBlackSheep's Avatar

Monte Of The Month -- August 2014
5 Year Member
3 Year Member1 Year Member
 
Join Date: Sep 2008
Location: Wyncote, PA
Posts: 24,648
Default RE: A few troubles, Signals, Power Window, Steering.

the window and climate control lights I have/had that problem.

open your window all the way, does it sound like it just fell to hard? Open it halfway, lift on the glass. Does it move a lot more than it should? I had just taken my door apart and noticed that a machine screw that holds the glass to the lever that moves the window up and down was somehow unscrewed and just sitting in my door. After I put that back in my window is perfect.

the climate control lights my driver's side one is shot, and my radio has 3 unlit buttons, I had heard they are not that easy to fix. nor are they a fuse.
Reply With Quote
  #3  
Old 09-24-2008, 02:18 AM
biggriggs's Avatar
5 Year Member
 
Join Date: Aug 2008
Location: Philadelphia, PA
Posts: 722
Default RE: A few troubles, Signals, Power Window, Steering.

As far as the steering:

Have you checked the power steering fluid level? About two years ago, mine was doing what you described (it's a 2001 LS). It was just low on fluid. Topped it back up that day, and haven't had any noise since.

-Riggs.
Reply With Quote
  #4  
Old 09-29-2008, 12:50 PM
Thread Starter
 
Join Date: Jan 2007
Posts: 24
Default RE: A few troubles, Signals, Power Window, Steering.

I'll have to top off the power steering fluid, it is just weird because its only after my car sits at night for a couple hour, I'll go out park my car, and when I drive home it makes the weird noices when turning and accelerating. Just really weird, any one else with this problem.
Reply With Quote
  #5  
Old 09-29-2008, 01:20 PM
Space's Avatar
5 Year Member3 Year Member1 Year Member
 
Join Date: Jul 2008
Location: Beach`in Florida
Posts: 33,585
Default RE: A few troubles, Signals, Power Window, Steering.

[align=center]Hi KW jr,[/align][align=center]Found the below in my ReSearch file, and it may give you some[/align][align=center]insight into power steering problems.[/align][align=center](Write up is about a 96 Monte Carlo)[/align][align=center]Hope it helps, until one of our expert members reads your[/align][align=center]post problems, and gives their opinion/solutions.[/align][align=center]Good Luck[/align][align=center]Click on below link[/align][align=center][:-][/align][align=center]http://www.popularmechanics.com/auto...36.html?page=2[/align][align=center][/align][align=center][:-]Oh-`no [:-][/align][align=center][/align][align=center][:-][/align][align=center]The leak in this pump is from rusted-through sheetmetal housing. Usual leakage mode is shaft seal or hoses. [/align]
Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
7th Gen ('06-'07): Power Steering Power Problem TomF106SS Monte Carlo Repair Help 7 10-06-2014 10:13 AM
Driver side window troubles F650 Interior/Audio/Visual Electronics 0 10-10-2011 07:54 AM
A Few Problems - Creaking, Cooling fan, tape deck, turn signals, tail & dash lights, window switch cmw239 Monte Carlo Repair Help 4 09-12-2007 06:52 PM
transmission troubles HWYRBRY Engine/Transmission/Performance Adders 8 04-11-2006 02:19 PM


Tags
2000, 2001, 86, car, carlo, dont, fell, fluid, fuse, monte, power, ss, steering, straight, window, windows

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Advertising
Featured Sponsors
Vendor Directory

All times are GMT -5. The time now is 12:00 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.