Interior/Audio/Visual Electronics Discuss your audio/visual system and your interior here.

turnsignal and breaklight issue

  #1  
Old 04-27-2011, 12:46 PM
97montecarlols's Avatar
Thread Starter
Join Date: Apr 2011
Location: stoystown, pa
Posts: 5
Default turnsignal and breaklight issue

just noticed that the breaklights and turnb signals on my 97 monte dont work.
3rd breaklight works, though.

checked all the fuses and they seem to be fine.
any ideas? help would be greatly appreciated
 
  #2  
Old 04-27-2011, 01:48 PM
Monte Of The Month -- April 2012
Monte Of The Month -- December 2014
10 Year Member
5 Year Member3 Year Member1 Year Member
Join Date: Sep 2008
Posts: 3,007
Default

The culprit is most likely a failing/failed multi-function switch (also referred to as a turn-signal switch)
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
thtGuy
Monte Carlo Repair Help
0
05-07-2013 08:09 AM
87monte02
Monte Carlo Repair Help
2
11-08-2008 04:50 PM
biggriggs
Monte Carlo Repair Help
6
09-30-2008 06:48 PM
full_monte
Monte Carlo Repair Help
1
09-17-2007 05:00 PM
firemansteve
General Monte Carlo Talk
7
07-04-2006 06:03 PM


Thread Tools
Search this Thread
Quick Reply: turnsignal and breaklight issue


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.