Interior/Audio/Visual Electronics Discuss your audio/visual system and your interior here.

tachometer and boost gauge problem

  #1  
Old 09-02-2011, 11:19 AM
5 Year Member3 Year Member1 Year Member
Thread Starter
Join Date: Sep 2011
Posts: 56
Default tachometer and boost gauge problem

Has anyone else had a problem with their tach or boost gauge? cause mine move still but just sit at the very bottom of each gauge
 
  #2  
Old 09-02-2011, 11:20 AM
ChibiBlackSheep's Avatar

Monte Of The Month -- August 2014
10 Year Member
5 Year Member3 Year Member1 Year Member
Join Date: Sep 2008
Location: Wyncote, PA
Posts: 24,824
Default

Most likely a stepper motor problem in your gauge cluster. They are known to fail.

Not too difficult of a fix.
 
  #3  
Old 09-02-2011, 11:24 AM
5 Year Member3 Year Member1 Year Member
Thread Starter
Join Date: Sep 2011
Posts: 56
Default

alright. is that something i could do myself then? or should i just take it to a shop?
 
  #4  
Old 09-02-2011, 11:27 AM
PacerSS's Avatar
Monte Of The Month -- February 2012
5 Year Member3 Year Member1 Year Member
Join Date: Jul 2010
Location: East Bay, CA
Posts: 783
Default

The boost gauge is electric?
 
  #5  
Old 09-02-2011, 11:36 AM
5 Year Member3 Year Member1 Year Member
Thread Starter
Join Date: Sep 2011
Posts: 56
Default

no? its the same as all my other gauges...they just sit at the way bottom and wont move to the right spot
 
  #6  
Old 09-02-2011, 11:57 AM
ChibiBlackSheep's Avatar

Monte Of The Month -- August 2014
10 Year Member
5 Year Member3 Year Member1 Year Member
Join Date: Sep 2008
Location: Wyncote, PA
Posts: 24,824
  #7  
Old 09-02-2011, 12:42 PM
5 Year Member3 Year Member1 Year Member
Thread Starter
Join Date: Sep 2011
Posts: 56
Default

alright that doesnt look too difficult thanks!
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Emnasty600
Monte Carlo Repair Help
8
07-25-2016 02:17 PM
04intimidatorssjmm
Interior/Audio/Visual Electronics
8
02-06-2011 02:48 PM
musclecarfreak1235
Engine/Transmission/Performance Adders
0
09-18-2009 10:09 AM
fever42
Engine/Transmission/Performance Adders
5
08-29-2009 11:48 PM
fxdrider
Engine/Transmission/Performance Adders
5
10-01-2007 09:39 AM


Thread Tools
Search this Thread
Quick Reply: tachometer and boost gauge problem


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.