General Monte Carlo Talk Talk about the Monte Carlo. Does not have to be your Monte. Can include pics and games.

7th Gen ('06-'07): My Ride is awful - South Jersey Area

  #1  
Old 08-04-2018, 10:22 AM
Thread Starter
Join Date: Mar 2017
Posts: 3
Angry My Ride is awful - South Jersey Area

Hey Monte Carlo world,

Does anyone else have an 2007 SS that rides like total ****?
Granted, I live in New Jersey and the roads are horrible but when I hit a bump it sounds like the whole suspension is going to be left on the ground. (front and back)
Anyone else have this issue? I had an 03 and it rode pretty nice compared to the 07, was just wondering.
If so, does anyone have or did something to correct it? I'm all ears.

Thanks, Rob
 
  #2  
Old 08-05-2018, 02:12 PM
ChibiBlackSheep's Avatar

Monte Of The Month -- August 2014
10 Year Member
5 Year Member3 Year Member1 Year Member
Join Date: Sep 2008
Location: Wyncote, PA
Posts: 24,822
Default

How many miles? Have you ever changed any parts of the suspension?

You might have bushings that are bad, need struts, etc.
 
  #3  
Old 08-06-2018, 10:52 AM
Thread Starter
Join Date: Mar 2017
Posts: 3
Unhappy 07 Monte Carlo SS

Hey Sheep,

Thanks for the reply, it just turned 100,000 miles and I've replaced everything:
Struts, bushings, lower control arms; tie rods etc. it was a 1-owner car that I purchased from a dealership.

Quite frankly, I'm baffled at this...
 
  #4  
Old 08-06-2018, 11:15 AM
drivernumber3's Avatar
Monte Of The Month -- May 2015
Monte Of The Month -- March 2017
5 Year Member
3 Year Member1 Year Member
Join Date: May 2013
Location: Nebraska
Posts: 4,208
Smile

So did the you replace the complete Strut with new springs etc. all the way around? Most of them ride pretty good. But it depends on the thing you notice the most. What is the worst thing about it?
Bottoms out maybe? Tracks funny. Noisy? What about the Tires? New or old miles? they maybe cupped from a balance issue or an alignment issue. Just guessing her these are the things I would check though.
 
  #5  
Old 08-06-2018, 01:08 PM
ChibiBlackSheep's Avatar

Monte Of The Month -- August 2014
10 Year Member
5 Year Member3 Year Member1 Year Member
Join Date: Sep 2008
Location: Wyncote, PA
Posts: 24,822
Default

What were your parts replaced with?

Do you happen to know?
 
  #6  
Old 08-15-2018, 06:31 AM
06mistreSS's Avatar
Monte Of The Month -- November 2012
Monte Of The Month -- August 2015
5 Year Member
3 Year Member1 Year Member
Join Date: Aug 2011
Location: Livingston Co, Michigan
Posts: 4,604
Default

Welcome! Yeah I'm pretty baffled at this as well. I'm at 95k miles and mine rides pretty damn good even being lowered. Seems like you have a lot of your bases covered. Does it just sound horrible or does it also feel horrible? I'm just thinking you might want to check some things like the condition of the exhaust system and if it's being held in position properly.
 

Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.