Showcase Your Ride Post Photo-shoots, Videos, Sound Clips about your ride!

6th Gen ('00-'05): real 'nas car

  #1  
Old 05-26-2016, 04:12 PM
Thread Starter
Join Date: Feb 2016
Location: Calgary
Posts: 15
Default real 'nas car

This is my 2001 Monte Carlo SS. It has a NA 3800, which I am intending on doing a top swap onto.
This car was given to me by a friend who just didn't want it anymore.

 

Last edited by bookermorgan; 05-26-2016 at 04:22 PM.
  #2  
Old 05-26-2016, 04:20 PM
Thread Starter
Join Date: Feb 2016
Location: Calgary
Posts: 15
Default

Driving it home, it had a bit of a drive shaft chatter, so I got underneath and had a look.





Tires are in great condition, right?
 

Last edited by bookermorgan; 05-26-2016 at 04:23 PM.
  #3  
Old 05-26-2016, 04:25 PM
Thread Starter
Join Date: Feb 2016
Location: Calgary
Posts: 15
Default

Popped the trunk and apparently the weather stripping is leaking. The spare tire well was filled with water. Drained it and pulled all the carpet out.
 
  #4  
Old 05-26-2016, 04:34 PM
Thread Starter
Join Date: Feb 2016
Location: Calgary
Posts: 15
Default

Replaced the left half shaft, and outer tie rod


Also replaced both front wheel hub assembly


Front rotors


Replaced rotors, calipers, pads, hoses

 

Last edited by bookermorgan; 05-26-2016 at 05:05 PM.
  #5  
Old 05-26-2016, 04:59 PM
shawn parker's Avatar
Monte Of The Month -- September 2016
1 Year Member
Join Date: Feb 2016
Location: Ronan MT
Posts: 637
Default

it's a shame how some people neglect their cars
 
  #6  
Old 05-26-2016, 05:07 PM
Thread Starter
Join Date: Feb 2016
Location: Calgary
Posts: 15
Default

Yep. There are other problems too.
The dash is intermittent.
It has an aftermarket remote start that seems to be the only way to start the car, if it feels like it.
I need to replace the accessory belt, but will do that with the swap.
Possible head gasket leak. Again, will deal with this during the top swap.
The speakers aren't working.
 
  #7  
Old 05-29-2016, 05:01 PM
Join Date: Mar 2016
Posts: 64
Default

I'm envious! I got an '01 same color as well with even more problems, and I bought it. It test drove great, but like after a week of driving it, it started showing all it's problems left and right... Good luck with all your repairs! It has a lot of potential, and frankly it's straight and good paint, so frankly the other stuff is just nuts and bolts.
 
  #8  
Old 05-29-2016, 05:03 PM
Join Date: Mar 2016
Posts: 64
Default

what size were the 3 wheel hub bolts and the half shaft nut?
 
  #9  
Old 05-31-2016, 03:27 PM
Thread Starter
Join Date: Feb 2016
Location: Calgary
Posts: 15
Default

Unfortunately I can't recall. I could check for you, if you just mean wrench/socket size...
 
  #10  
Old 05-31-2016, 03:49 PM
Join Date: Mar 2016
Posts: 64
Default

yeah, I've been told the axle nut is either a 33, 35 or 36mm, I haven't found any info on the 3 wheel hub bolt sizes yet...
 

Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.