6th Gen ('00-'05): Monte Carlo 03 ss parasitic drain clus/BCM /data link connector fuse draining battery - Monte Carlo Forum - Monte Carlo Enthusiast Forums

Go Back  Monte Carlo Forum - Monte Carlo Enthusiast Forums > General Forums > Monte Carlo Repair Help
Reload this Page >

6th Gen ('00-'05): Monte Carlo 03 ss parasitic drain clus/BCM /data link connector fuse draining battery

Monte Carlo Repair Help Have a Monte problem and need help? Good at troubleshooting? Discuss it here!

6th Gen ('00-'05): Monte Carlo 03 ss parasitic drain clus/BCM /data link connector fuse draining battery

  #1  
Old 09-13-2018, 01:24 PM
Thread Starter
Join Date: Sep 2018
Posts: 3
Default Monte Carlo 03 ss parasitic drain clus/BCM /data link connector fuse draining battery

Clus/BCM/ data link connector fuse draining battery while engine not running voltage reading is 02.9 I don't know where to go from here
 
  #2  
Old 09-13-2018, 01:47 PM
Thread Starter
Join Date: Sep 2018
Posts: 3
Default Parasitic drain 03 Monte Carlo ss

Mc battery is dead if fuse that reads cluster BCM data link battery is not removed anybody know what would be causing this?
 
  #3  
Old 09-27-2018, 01:50 PM
Join Date: Sep 2018
Location: Indiana
Posts: 4
Default

I had the same parasitic drain issue with my 2005 LT. What I did was cleaned my battery cables and replaced the battery rundown protection relay ( located on my LT in the passenger side fuse block ). Idk if it was just a loose/corroded batty cable or relay but after I done that I havenít anymore battery drains. Hope this helps.
 

Thread Tools
Search this Thread
Advertising
Featured Sponsors
Vendor Directory

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.