brake lights out - Monte Carlo Forum - Monte Carlo Enthusiast Forums


Reply
 
 
 
Thread Tools Search this Thread
  #1  
Old 08-25-2013, 03:06 PM
Thread Starter
 
Join Date: Aug 2013
Posts: 2
Default brake lights out

my brake lights are out the two at the bottom and my turn signals light are out but my hazard lights still work can someone tell me what the problem is please
Reply With Quote
  #2  
Old 08-25-2013, 03:19 PM
STUMPMI's Avatar

Monte Of The Month -- February 2013
5 Year Member
3 Year Member1 Year Member
iTrader: (1)

 
Join Date: Dec 2011
Location: Taylor Michigan
Posts: 9,944
Default

Ive never had a problem with mine....

Im guessing you have checked all the fuses? In the dash as well as under the hood? Are all the bulbs good? Does your 3rd brakelight still working?


Heres a guess:
maybe its the Multi function Module? Its in the steering column....

Have any idea what may have caused them to go out in the first place?

Hope this helps!
maybe someone else will chime in with some other ideas/advise!
Thanks for Joining the MCF!
Were always happy to help other Monte Carlo Owners.
Reply With Quote
  #3  
Old 08-25-2013, 03:56 PM
Thread Starter
 
Join Date: Aug 2013
Posts: 2
Default

yes i check all the fuses and the one in the middle still works the bulbs are new and the brake switch
Reply With Quote
  #4  
Old 08-25-2013, 04:00 PM
STUMPMI's Avatar

Monte Of The Month -- February 2013
5 Year Member
3 Year Member1 Year Member
iTrader: (1)

 
Join Date: Dec 2011
Location: Taylor Michigan
Posts: 9,944
Default

Quote:
Originally Posted by montacarlo98 View Post
yes i check all the fuses and the one in the middle still works the bulbs are new and the brake switch

My wifes 99 blazer did the same thing....

It was the Multifunction Module. (Its in the steering column)

We also tried replaceing the brake light switch...(No help)
Til we found out it was the Multifunction Module...
Reply With Quote
  #5  
Old 08-26-2013, 09:55 AM
skylark65's Avatar
Monte Of The Month -- September 2009
5 Year Member3 Year Member1 Year Member

 
Join Date: Aug 2008
Location: Bushkill, PA
Posts: 3,279
Default

i would second it being the multifunction switch in the steering column, mine was bad when i got my '97 monte and it causes those exact symptoms. good news is the part is under $100, bad news is it is kinda involved to replace ( need to remove the airbag, pull the steering wheel and more in the steering column to get to it). so unless you're a skilled mechanic i would reccomend having a shop do the work.
Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Headlights, gauge lights, radio lights all cut out THAV Monte Carlo Repair Help 3 09-03-2014 07:50 PM
low brake fluid/brake/trac loc lights hotrodharley Monte Carlo Repair Help 2 10-11-2013 07:13 AM
oem stock cd/tape player out of o3 monte carlo and 2 blacked out tail lights billyjblunt79 PRIVATE For Sale/Trade Classifieds 0 05-03-2013 12:59 PM
HELP: 1997 Monte No brake lights or interior lights... Zackb911 Monte Carlo Repair Help 0 12-22-2006 07:22 PM


Tags
1997, 1999, 97, 99, bad, brake, brakes, carlo, inoperable, light, lights, monte, multifunction, switch, work, working

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 02:30 AM.