brake lights not working - Monte Carlo Forum - Monte Carlo Enthusiast Forums

Monte Carlo Repair Help Have a Monte problem and need help? Good at troubleshooting? Discuss it here!

brake lights not working

Reply

 
 
 
  #1  
Old 06-04-2010, 10:26 PM
Thread Starter
Join Date: Sep 2007
Posts: 2
Default brake lights not working

I have a 99 Z34 that the brake lights work part time. It seems that when I first get into the car and start it up they work fine until I'm driving down the road and use the turn signals then they quit. The turn signals work fine and the third brake light works. Any idea what I need to check?
 
Reply With Quote
  #2  
Old 06-04-2010, 11:20 PM
Monte Of The Month -- April 2012
Monte Of The Month -- December 2014
5 Year Member
5 Year Member3 Year Member1 Year Member
Join Date: Sep 2008
Posts: 2,963
Default

Check the bulbs, make sure there's a clean connection. If that doesn't work, it's probably your multifunction switch going bad.
 
Reply With Quote
  #3  
Old 08-02-2014, 09:59 AM
Join Date: Aug 2014
Posts: 1
Default

Sounds like your multifunction switch located in the steering column. Same thing happened to my 99 monte carlo...had switch replaced...fixed the problem
 
Reply With Quote
  #4  
Old 08-03-2014, 02:21 PM
Join Date: Jun 2014
Posts: 19
Default

yea, i would agree with the multifunction switch also
 
Reply With Quote
  #5  
Old 08-03-2014, 04:00 PM
STUMPMI's Avatar

Monte Of The Month -- February 2013
5 Year Member
3 Year Member1 Year Member
iTrader: (1)
Join Date: Dec 2011
Location: Taylor Michigan
Posts: 9,944
Default

Mines starting to the same thing...
Someone pointed out that mine was failing...
Its a common problem for 1999...
We had to replace it in my wifes 1999 Blazer as well.
 
Reply With Quote
  #6  
Old 06-21-2017, 06:40 PM
Join Date: Jun 2017
Posts: 1
Default 1980 monte carlo

my taillights dont work, headlights works just fine
 
Reply With Quote
  #7  
Old 06-21-2017, 10:52 PM
Monte Of The Month -- April 2012
Monte Of The Month -- December 2014
5 Year Member
5 Year Member3 Year Member1 Year Member
Join Date: Sep 2008
Posts: 2,963
Default

You might want to start a new thread, this one is old, and for 95-99 Monte Carlo's...

Check the harness to ensure it's getting power to the bulbs. Do the brake lights work when the brake is pressed?
 
Reply With Quote
Reply
 
 
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
jworm98
Monte Carlo Repair Help
15
05-14-2017 03:59 AM
dtesgue
Monte Carlo Repair Help
0
05-17-2012 09:17 PM
bitsy5085
Monte Carlo Repair Help
2
03-14-2009 05:14 PM
thedude
Monte Carlo Repair Help
0
09-01-2006 10:26 PM


Thread Tools
Search this Thread
Advertising
Featured Sponsors
Vendor Directory