Monte Carlo Repair Help Have a Monte problem and need help? Good at troubleshooting? Discuss it here!

2004 Monte Carlo Power Steering Issue

  #1  
Old 08-21-2018, 09:08 AM
Thread Starter
Join Date: Aug 2018
Posts: 2
Default 2004 Monte Carlo Power Steering Issue

I have a 2004 Monte Carlo. Both inner tie rods were replaced and shortly after my son notice the steering would just quit in mid turn or slow speed turning. Will happen more under a left turn than right. I since then have flushed the system with BG products. This did not help. The power steering pump makes no noises and no signs of leaks. Any ideas from you Monte Carlo mechanical enthusiast??
 
  #2  
Old 08-24-2018, 11:11 PM
The_Maniac's Avatar

Monte Of The Month -- December 2011
Monte Of The Month -- September 2014
5 Year Member
3 Year Member1 Year Member
iTrader: (2)
Join Date: Apr 2010
Location: Mentor, Ohio
Posts: 10,873
Default

Kinks in the line? Air in the system? Low fluid level? Blockage in a line? Those are my first guesses.

If you start the car, and in PARK, rotate the wheel from end to end 1-2 times, shut the car off and check the fluid, does it look foamy/frothy? If so, that suggests air in the system.

If everything checks out, then it might be a pump or steering rack.
 
  #3  
Old 08-25-2018, 08:05 AM
Thread Starter
Join Date: Aug 2018
Posts: 2
Default

Yeah no signs of a kinked line or any low fluid. It acts like a failing rack and pinion. I ordered one and will have it installed this week. I'll keep ya posted. Thanks
 

Thread Tools
Search this Thread
Advertising
Featured Sponsors
Vendor Directory

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.