Headers/Intake/Exhaust Custom Exhaust? New Headers? Need Opinions on Intakes? Discuss making your ride breathe better here.

1996 Z34 Issue??

  #1  
Old 07-09-2008, 11:08 PM
Thread Starter
Join Date: Jul 2008
Posts: 1
Default 1996 Z34 Issue??

I have a 1996 Z34. Owned it since new, of course it has had the typical issues.But still love the car. I have had miss problems, have been letting it go because I didn't have time to put in 3 hours to change plugs/wires. Died on me recently, ran like hell and wouldn't go. Had it towed back, replaced wires and plugs. When I started it up purred like a kitten, but when I took it out got to about 30 and feels like it is towing a house. Settled on cat must be plugged and might have been contributing to my miss condition that has plagued me for some time. Started it up tonight again after a few weeks on vacation. Idles well, but still not accelerating above 20/30 mph. Looked under car and didn't see cat glowing, didn't drive it far though. Thinking of just cutting off the cat and see what happens, would it be better to cut off or disconnect pipe at header connection or other ideas?

230K miles, never changed cat.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
holesremy
Monte Carlo Repair Help
0
09-27-2009 06:41 PM
scoutster
Monte Carlo Repair Help
3
09-03-2009 03:58 PM
scoutster
General Monte Carlo Talk
0
08-29-2009 05:09 PM
Maverick
Showcase Your Ride
8
12-14-2006 05:14 PM
fastback4
Engine/Transmission/Performance Adders
2
12-10-2006 11:29 PM


Thread Tools
Search this Thread
Quick Reply: 1996 Z34 Issue??


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.