Engine/Transmission/Performance Adders Chat about your engine, transmission, nitrous, superchargers, turbos, and tuning.
Sponsored by:
Sponsored by:

No Acceleration

  #1  
Old 06-16-2017, 04:19 PM
mc1978's Avatar
5 Year Member
3 Year Member1 Year Member
Thread Starter
Join Date: Mar 2013
Posts: 152
Default No Acceleration

I'm having a rough time with getting the car to highway speeds. Once the car gets to 50MPH, i can put the gas pedal on the floor and the car doesn't accelerate. Today I had a rough time with accelerating from a red light. Where can I look for possibilities as to what is causing this? Fuel filter? Is my throttle cable stretched?
 
  #2  
Old 06-16-2017, 10:25 PM
plumbob's Avatar
Monte Of The Month -- January 2016
5 Year Member
3 Year Member1 Year Member
Join Date: Feb 2013
Location: Pacific NW
Posts: 2,280
Default

How resent was your last tune up including a throttle body cleaning, particularly the screen? Could be as simple as a clogged air filter.
 
  #3  
Old 06-17-2017, 12:40 AM
mc1978's Avatar
5 Year Member
3 Year Member1 Year Member
Thread Starter
Join Date: Mar 2013
Posts: 152
Default

I've never had one done on it. I did have the intake tube off and I inspected the TB. It looked clean. What could possibly clog my air filter? How much would a tune up be for a 2000 LS?
 
  #4  
Old 06-17-2017, 09:10 AM
plumbob's Avatar
Monte Of The Month -- January 2016
5 Year Member
3 Year Member1 Year Member
Join Date: Feb 2013
Location: Pacific NW
Posts: 2,280
Default

I don't know the history of your car or what conditions you drive it in, but the general rule of thumb is to do a tune up every 100,000 miles, some things sooner depending on the type of use. One of those things is the air filter which clogs with particulates in the air. I would definitely replace that if you never have. I change mine every 30,000 miles.
Depending on the definition of "tune-up" A shop might charge $200-300 depending on what they do. I would also recommend a transmission fluid and filter change if that hasn't been done. Add $150-200 for that. And another $100 for an EGR passage cleaning, a common problem with 3100 and 3400 engines.

Here's a link to a thread covering a 100,000 mile, and regular maintenance:
https://montecarloforum.com/forum/fw...0-miles-46078/
 
  #5  
Old 06-17-2017, 11:50 AM
mc1978's Avatar
5 Year Member
3 Year Member1 Year Member
Thread Starter
Join Date: Mar 2013
Posts: 152
Default

Acceleration problem solved...the throttle cable sheath was obstructing the throttle body from opening all the way. Once I put it back where its supposed to be, the throttle body was freed up. While I was at it, I also cleaned my MAF sensor as well.
 
  #6  
Old 06-17-2017, 07:36 PM
Sidestreet's Avatar
Monte Of The Month -- January 2017
3 Year Member
1 Year Member
Join Date: Apr 2015
Location: Papillion, NE
Posts: 287
Default

Gotta love those zero-cost simple solutions!
 

Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.