Engine/Transmission/Performance Adders Chat about your engine, transmission, nitrous, superchargers, turbos, and tuning.
Sponsored by:
Sponsored by:

7th Gen ('06-'07): LS4 Question

  #1  
Old 01-08-2018, 11:59 AM
5 Year Member
3 Year Member1 Year Member
Thread Starter
Join Date: Dec 2010
Location: Brevard County, FL
Posts: 508
Default LS4 Question

In a (so far unsuccessful) attempt to replace the plug on cylinder 1, I had to unplug the sensor, or whatever it is, next to the plug wire.

What is this thing?
 
  #2  
Old 01-08-2018, 01:07 PM
ChibiBlackSheep's Avatar

Monte Of The Month -- August 2014
10 Year Member
5 Year Member3 Year Member1 Year Member
Join Date: Sep 2008
Location: Wyncote, PA
Posts: 24,822
Default

Are you referencing the coil packs?

Or a different sensor near the engine?
 
  #3  
Old 01-08-2018, 11:10 PM
5 Year Member
3 Year Member1 Year Member
Thread Starter
Join Date: Dec 2010
Location: Brevard County, FL
Posts: 508
Default

A different sensor ON the engine.
 
  #4  
Old 01-09-2018, 10:54 AM
ChibiBlackSheep's Avatar

Monte Of The Month -- August 2014
10 Year Member
5 Year Member3 Year Member1 Year Member
Join Date: Sep 2008
Location: Wyncote, PA
Posts: 24,822
Default

If it's the sensor right near the front exhaust manifold and plug #1 it should be the engine coolant temp sensor

If this also isn't correct, can you provide a picture of the sensor in question. Thanks!
 

Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.