Monte Carlo Forums

Go Back   Monte Carlo Forum - Monte Carlo Enthusiast Forums > General Forums > Monte Carlo Repair Help
Sign in using an external account
Register Forgot Password?
Search


Welcome to the Monte Carlo Forum - Monte Carlo Enthusiast Forums.
If this is your first visit, be sure to check out the FAQ by clicking the link above. You may have to register before you can post: click the register link above to proceed. To start viewing messages, select the forum that you want to visit from the selection below.

Reply
 
 
 
 
LinkBack Thread Tools Search this Thread
  #1  
Old 12-26-2012, 06:14 PM
 
Trader Rating:(0)
Join Date: Dec 2012
Posts: 8
Default Bad sensor? Low Brake fluid , Brake and Trac off alarms

i'm hoping this is only a bad sensor , but after clipping a pothole i got all 3 of these warning lights at the same time : Low Brake Fluid, Brake and Trac Off.
i could see the brake and trac off lights only being a sensor, but the low brake fluid also is what i cant figure out ....any ideas?

thanks
Reply With Quote
  #2  
Old 12-26-2012, 08:06 PM
seawolf18's Avatar
3 Year Member

 
Trader Rating:(0)
Join Date: Nov 2009
Location: South Dakota
Posts: 166
Send a message via MSN to seawolf18 Send a message via Yahoo to seawolf18
Default

Did you actually check the brake fluid and make sure it was still full? Sounds like an ABS wheel sensor or the wiring for it. If the wire gets disconnected it can make those warnig lights go on. I have also seen a bad battery make the ABS and brake warning light come on also. If you have an ABS problem, the traction control will not work until the ABS is fixed.
__________________
The Hot Rodders Prayer:

As I lay rubber down to street, I pray for traction I can keep, but if I spin and begin to slide, please dear God protect my ride. -Amen
Reply With Quote
  #3  
Old 12-26-2012, 08:10 PM
Jomao_o's Avatar
5 Year Member3 Year Member1 Year Member

 
Trader Rating:(0)
Join Date: Mar 2009
Location: MD.
Posts: 5,104
Jose M Caballero JomaMC
Send a message via Yahoo to Jomao_o
Default

My low brake fluid light came on when I tugged on the connection underneath it. Check it, unplug/plug to see if goes away.
__________________


Owned sinced 09'... Sits at 162K
Reply With Quote
  #4  
Old 12-26-2012, 08:35 PM
 
Trader Rating:(0)
Join Date: Dec 2012
Posts: 8
Default

i was leaning towards it being the abs sensor....checked brake fluid and level was good. is an ABS sensor difficult to replace?
Reply With Quote
  #5  
Old 01-05-2013, 03:33 PM
 
Trader Rating:(0)
Join Date: Dec 2012
Posts: 8
Default

turns out it was the Brake Fluid level sensor.....nice easy $12 fix.
Reply With Quote
  #6  
Old 01-12-2013, 07:54 AM
 
Trader Rating:(0)
Join Date: Jan 2013
Posts: 2
Default Low fluid sensor

Where was the sensor located?
Reply With Quote
  #7  
Old 01-12-2013, 07:54 AM
 
Trader Rating:(0)
Join Date: Jan 2013
Posts: 2
Default

Where was the sensor located?
Reply With Quote
Old 01-12-2013, 07:54 AM
 
 
 
Reply

Tags
2004, abs, brake, break, carlo, chevrolet, control, fluid, level, light, low, monte, sensor, trac, traction, trip


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Advertising

Featured Sponsors
Vendor Directory
Our Sponsors

All times are GMT -5. The time now is 11:39 AM.

Internet Brands, Inc.



SEO by vBSEO ©2010, Crawlability, Inc.