New Member Area New to Monte Carlo Forum? Stop in tell us about you.

07 ss

  #1  
Old 05-13-2018, 10:25 PM
Thread Starter
Join Date: Jul 2015
Posts: 3
Default 07 ss

My name is Jason I have a 07 Monte Carlo SS black on black with all of the options. So far I have the normal problems, rust in the rear wheel wells, blend for actuators, power steering pump, transmission, and front light socket. I love my car I just wish they didn't have so many common problems. Did I miss anything? Are there more thing i should be looking for?
 
  #2  
Old 05-14-2018, 03:57 AM
Join Date: Nov 2017
Location: Isanti, MN
Posts: 773
Default

Welcome to the forums.
 
  #3  
Old 05-14-2018, 07:33 AM
chifan's Avatar
Monte Of The Month -- June 2016
5 Year Member
3 Year Member1 Year Member
Join Date: Apr 2013
Location: Paragould, Arkansas
Posts: 543
Default

Welcome to MCF, Jason!



My '07 also had the rust in the right rear wheel well, and I've just learned to live with the blend door actuators, as I've replaced them a couple of times already... So far, no transmission issues though... Throw up some pics of your ride when you can!
 
  #4  
Old 05-15-2018, 02:04 AM
carid's Avatar
Premium Sponsor
Join Date: May 2013
Location: Cranbury, New Jersey, United States
Posts: 415
Default

Welcome aboard! Hope you get your issues fixed up. Post some pics of your Monte for us so we can see what you're working with.
 

Thread Tools
Search this Thread
Advertising
Featured Sponsors
Vendor Directory

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.