Monte Carlo Repair Help Have a Monte problem and need help? Good at troubleshooting? Discuss it here!

Fuse Box Problem

  #1  
Old 03-14-2006, 04:28 PM
Thread Starter
Join Date: Mar 2006
Location:
Posts: 5
Default Fuse Box Problem

I have an 85 ss. The headlights, horn, dome light, key buzzer, etc. will not come on until I press the brake pedal. For some reason, the brake switch is activating the fuse box when pressed.

Also, there are three "battery" slots on the bottom of the fuse box under the dash. One is for Accessory...the other two do not have anything plugged into them. The accessory one has continuous battery power, but the other two will not light my test light until I press the brake pedal.

I don't know why these two slots do not have continuous power. I notice when they have power, everything seems to work fine, but only when I press the brake.

How can the brake switch send power to these slots? Brake lights work when the pedal is pressed.

It seems like, after a while, I will go back outside and put the key in and it will buzz again (without wiggling anything). I pushed the horn button and it went off.

When I turn the key to the on position, the radio works and gauges flick.[:@][:@][:@][&o]


Any help is appreciated...

Thanks
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
MeanShwaMonte
Detailing
42
05-01-2015 08:17 AM
SpinEm_90
General Monte Carlo Talk
16
02-18-2011 07:41 PM
ATP03SS
Interior/Audio/Visual Electronics
9
02-18-2011 09:18 AM
04TurboSS
PRIVATE Wanted Classifieds
5
05-18-2010 10:57 AM
TribalMonte
Monte Carlo Repair Help
2
09-08-2007 03:22 PM


Thread Tools
Search this Thread
Quick Reply: Fuse Box Problem


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.