Interior/Audio/Visual Electronics Discuss your audio/visual system and your interior here.

Jaws2008 System Build

  #1  
Old 06-22-2011, 01:02 AM
jaws2008's Avatar

Monte Of The Month -- April 2011
GOT SPL
Thread Starter
Join Date: Oct 2008
Location: Lancaster PA
Posts: 1,571
Default Jaws2008 System Build

Hi all, My other thread about my build is a bit messy and unorganized a bit... So I Thought I could summarize it all right up here, in order, exactly what I did etc.. And with my new updates..

Okay here we go.

First thing we did was make the box and the start of the amp rack.. In the picture below we had flipped the box around so the port was on the other side, it fit better and was more centered. (I dont have a pic of the Amp rack empty)


Then Some of the trim pieces were made. As well as mounting The JL amp in the pics below (pics of how that is mounted will be later).



Also the installation of the RE Audio MT 15" Sub. Its a DVC sub wired in parallel to .5 ohm.



Then the trim pieces were wrapped in Black sued.



Continued....
 
  #2  
Old 06-22-2011, 01:03 AM
jaws2008's Avatar

Monte Of The Month -- April 2011
GOT SPL
Thread Starter
Join Date: Oct 2008
Location: Lancaster PA
Posts: 1,571
Default

Continued...


Then of course was the installation of the new sub amp. US AMPS MD 3D







Then I upgraded my Head Unit once again.. Kenwood DNX9960






Then Planning for Custom door Panels with multiple speakers I picked up this.. Rockford Fosgate Power T600-4


I then Installed a Optima Yellow Top battery up front.. Pics to follow.

Then Painted etc.. my amp rack...

In the above pic the Rockford amp is not hooked up since I dont have the speakers I want to hook up to it yet, but it was in for show and test fit.


Continued...
 

Last edited by jaws2008; 06-22-2011 at 01:10 AM.
  #3  
Old 06-22-2011, 01:04 AM
jaws2008's Avatar

Monte Of The Month -- April 2011
GOT SPL
Thread Starter
Join Date: Oct 2008
Location: Lancaster PA
Posts: 1,571
Default

Continued...


I then decided I need to upgrade wiring.. 0 gauge is what was needed for the main power wire, as well getting some 0 gauge directly to the Subwoofer amp.



Also picked up some needed accessories...



^^^x2

^^^x2


This brings up about to current time. The 0awg is in pics to follow. But leads us to my new fronts for the doors(I know I promised Rockford Fosgate T1 6.5 Component Separates but I couldn't help my self so)...
RE Audio XXX 6.5 Component separates... And yes that 150RMS each speaker not for the pair.









So at the current time my setup is..
Kenwood DNX9960
RE Audio MT 15" Sub
US AMPS MD 3D amp at .5ohm
JL Audio Slash 300/4
Rockford Fosgate Power T600-4
JL Audio TR 6x9
RE Audio xxx 6.5" Component Separates
Optima Yellow Top Battery

Ill post some new vids soon as well.. Ill put a link to them in this thread..
 

Last edited by jaws2008; 06-22-2011 at 01:15 AM.
  #4  
Old 06-22-2011, 01:26 AM
Join Date: Jun 2011
Location: Iowa
Posts: 3,868
Default

wow thats a lot of equipment looks great man
 
  #5  
Old 06-22-2011, 04:57 AM
Join Date: Jun 2011
Location: SEA
Posts: 37
Default

how much was that roll of O gauge?
 
  #6  
Old 06-22-2011, 07:43 AM
red04montels's Avatar
Monte Of The Month -- September 2010
5 Year Member
3 Year Member1 Year Member
Join Date: Aug 2009
Location: Wisconsin
Posts: 9,356
Default

looks good man, can't wait to see it finished!
 
  #7  
Old 06-22-2011, 02:32 PM
jaws2008's Avatar

Monte Of The Month -- April 2011
GOT SPL
Thread Starter
Join Date: Oct 2008
Location: Lancaster PA
Posts: 1,571
Default

Originally Posted by M.SEA View Post
how much was that roll of O gauge?
got it on sale at audiosavings.com for like $80. Its normally over $150 for that size roll.
 
  #8  
Old 06-22-2011, 02:42 PM
ChibiBlackSheep's Avatar

Monte Of The Month -- August 2014
10 Year Member
5 Year Member3 Year Member1 Year Member
Join Date: Sep 2008
Location: Wyncote, PA
Posts: 24,824
Default

I think when I'm done with my car I will finally dabble into the audio. That stuff looks great man!
 
  #9  
Old 06-22-2011, 04:52 PM
jaws2008's Avatar

Monte Of The Month -- April 2011
GOT SPL
Thread Starter
Join Date: Oct 2008
Location: Lancaster PA
Posts: 1,571
Default

Thanks all. Im working on the 6.5s as I type im just running into big trouble putting them in because they are way to deep and the window gets in the way... Im trying to put them in the stock location for now until I get all the needed equipment and time to do custom panels.
 
  #10  
Old 06-22-2011, 05:22 PM
xxtheshockerxx's Avatar
Monte Of The Month -- October 2011
Monte Of The Month -- July 2014
RED DEVIL
5 Year Member3 Year Member1 Year Member
Join Date: Dec 2010
Location: Madrid, Iowa
Posts: 5,982
Default

that is gonna be a really awesome system when you get it all done
 

Thread Tools
Search this Thread
Quick Reply: Jaws2008 System Build


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.