Engine/Transmission/Performance Adders Chat about your engine, transmission, nitrous, superchargers, turbos, and tuning.
Sponsored by:
Sponsored by:

Trans issue.. Pls help

  #1  
Old 11-09-2017, 02:43 PM
wht02monte's Avatar
5 Year Member
3 Year Member1 Year Member
Thread Starter
Join Date: Oct 2009
Location: around cal city,il
Posts: 3,141
Default Trans issue.. Pls help

So im having a problem that SEEMS like the trans is slipping. Slipping is the best way I can describe it but I dont think its actually slipping.. It happens under light acceleration and seemingly only in 3rd and 4th.. No codes..

So for example say im going 45 and start speeding up real nice and slow.. Itll rev up about 1000 rpm more than it should, then drop back down to what it should be at, then back up 1000, back down over and over.. "What it should be at" is another hard to describe thing..

I just had this trans rebuilt (full rebuild) maybe 15-20k miles ago and I dont beat the hell out of it.

Fluid is a bit darker than it was a few weeks ago and a mechanic said it seems "sticky" but I dont feel it being sticky..

Mechanic says possibly the torque converter clutch.. Now I know very little about automatic transmissions so what do you think.. Any input would be very appreciated seeing as I already am uncomfortable with this shop and feel like I may have been "ripped off" for lack of a better term.. I mean, when should a trans fail after just being rebuilt??

Im bringing it in for an inspection as its under warranty and just want to know if theres anything I should prepare for..

Thanks much..
 

Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.