Monte Carlo Forums

Go Back   Monte Carlo Forum - Monte Carlo Enthusiast Forums > Your Ride > Engine/Transmission/Performance Adders
Sign in using an external account
Register Forgot Password?
Search


Welcome to the Monte Carlo Forum - Monte Carlo Enthusiast Forums.
If this is your first visit, be sure to check out the FAQ by clicking the link above. You may have to register before you can post: click the register link above to proceed. To start viewing messages, select the forum that you want to visit from the selection below.

Reply
 
 
 
 
LinkBack Thread Tools Search this Thread
  #1  
Old 11-20-2012, 06:52 PM
JC Colon`'s Avatar
Monte Of The Month -- May 2014
1 Year Member

 
Trader Rating:(0)
Join Date: Nov 2012
Location: Garfield NJ
Posts: 1,576
JC Colon
Default 02 M.C. SS Trouble Code P0102 and P0122

Hello Experts,
So I've change the following:
MAP, MAS, TPS, IAC. The ECM wa s re-programmed cause it hsd s Buick Turbo program in it. All in the ladt 7 months. The MAS was replaced last week.
Symptoms:
Starts and Stalls - intermittantly
Engine revs to 3000 rpm on startup - intermittantly
Engine starts and ildes normally but will hold last rpm level then gradually drift down to about 1000 rpm.
Engine runs fine then surges then drives the car for me.
Gas mileage is 14mpg.
After I changed the MAS, the service engine light came on. I got 4 engine codes. U1000, U1016, P0102 & P0122. As I said, I've replaced both the MAS & TPS.
I think I may be having an DCM connectivity problem. And now I am out of the type of funds I need to take it to a shop. So I HAVE to fix this myself. :'( But this is taking my experience to the limit. Please help! I feel like I've got an old Hoopdee that I bought just to get to and from work. It's depressing and frustrating. I don't even take my Monte above 55mph. Help me please? I need a 70mph fix bad! :'( :'( :'(
Reply With Quote
  #2  
Old 11-24-2012, 08:30 AM
JC Colon`'s Avatar
Monte Of The Month -- May 2014
1 Year Member

 
Trader Rating:(0)
Join Date: Nov 2012
Location: Garfield NJ
Posts: 1,576
JC Colon
Default

Wow! Guess I must be in t world of hot doodoo? I sometimes it's good to be the first at something. But this isn't one of those times! But that's ok cause if this ever happens to anyone else I'll be able to help them. So there's a silver lining in this cloud! ;-)
Reply With Quote
  #3  
Old 11-25-2012, 10:00 PM
The_Maniac's Avatar

Monte Of The Month -- December 2011
3 Year Member1 Year Member

 
Trader Rating:(0)
Join Date: Apr 2010
Location: Mentor, Ohio
Posts: 7,948
Default

Without researching the trouble codes, I'd inspect the CAT and look for vacuum leaks. To look for Vac Leaks, get a can of starting fluid, while the engine is idling, mist the starting fluid around. If you have a leak, the fluid gets sucked in the leak, you'll notice a change in the idle. If you find a spot where this happens, inspect it (with the engine off) for problems.

As for the cat, after driving the car, leave it running, look under the car, if the cat is clogged, that thing will normally get cherry red. If it is, there is your issue.

Again, just off the top of my head ideas with no research on those trouble codes.
__________________
-Jason
Check out my websites below:
- 1984 Camaro Z28 5.0 Liter HO Restore Project/Big Toy
- 2004 Monte Carlo SS 3800 N/A See website for MOD List
- 2004 Grand Am GT SC/T - Current daily driver
Reply With Quote
  #4  
Old 11-26-2012, 09:52 AM
JC Colon`'s Avatar
Monte Of The Month -- May 2014
1 Year Member

 
Trader Rating:(0)
Join Date: Nov 2012
Location: Garfield NJ
Posts: 1,576
JC Colon
Default

Thanks for the reply. I was thinking about the CAT. Hoping that's not it. Wanna do the hole exhaust this spring. I don't get a Bank 1 o.s. code but i know that doesn't mean the cat is good. The haven't done a leak check yet cause the Mrs. put my chiltons away and doesn't know were. The Computer had to be rewired cause it was crushed in an accident before I got it. So I'm thinking the combo of the wires being shorted and all the bumping from the 22s cause the harness to come loose. Now I just have to battle the cold to get all this checked. Oh well, you v otta do what you gotta do right! I'll post results. B-)
Reply With Quote
Old 11-26-2012, 09:52 AM
 
 
 
Reply

Tags
02, 2002, 3000, carlo, chevy, code, drops, engine, grand, htr, monte, obd, p0122, revs, rpms, start, u1000


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Advertising

Featured Sponsors
Vendor Directory
Our Sponsors

All times are GMT -5. The time now is 04:07 AM.

Internet Brands, Inc.



SEO by vBSEO ©2010, Crawlability, Inc.