Monte Carlo Forums

Go Back   Monte Carlo Forum - Monte Carlo Enthusiast Forums > Your Ride > Engine/Transmission/Performance Adders
Sign in using an external account
Register Forgot Password?
Search


Welcome to the Monte Carlo Forum - Monte Carlo Enthusiast Forums.
If this is your first visit, be sure to check out the FAQ by clicking the link above. You may have to register before you can post: click the register link above to proceed. To start viewing messages, select the forum that you want to visit from the selection below.

Reply
 
 
 
 
LinkBack Thread Tools Search this Thread
  #1  
Old 09-02-2009, 04:49 PM
 
Trader Rating:(0)
Join Date: May 2008
Posts: 19
Question 01 SS Shaking Terribly

Hi all,

My monte is shaking under acceleration and idiling very low while in park and at stop lights (almost stalls). It smells horrible. Sulfur and ammonia combined. It barely makes it up hills and shakes immensely when doing so. I can reach the speeds I need to but it takes a while to get there and it feels like the engine is going to blow.

My check engine light begins to flash when accelerating.

I have changed the following the last 2 days:
I changed these things because of the above mentioned (None of these repairs worked)

Catalytic Converter
Plugs
Plug wires
Fuel Filter

Anyone have any ideas?

Thanks for your time

Last edited by xman23; 09-03-2009 at 11:43 AM.
Reply With Quote
  #2  
Old 09-02-2009, 04:59 PM
Space's Avatar
5 Year Member3 Year Member1 Year Member
 
Trader Rating:(0)
Join Date: Jul 2008
Location: Beach`in Florida
Posts: 32,191
Banned from Facebook Banned Empty Space They won't let me play anymore Revoked X-Rated
Default

Hi Xman, I feel your pain $$ 4-Sure. Check back on your post & hopefully one of expert tech will have a suggestion for you.,..Until then check out my search results...Good Luck

ACDelco | Auto Service & Car Maintenance | Troubleshooting

Noises, smells & leaks are all signs that something could be wrong with your vehicle. ... Detonation, Mild to severe ping, usually worse under acceleration and load. ... Car may also shake. Sluggish, Engine delivers limited power under load or at high ... Continuous, heavy sulfur odor, like rotten eggs, Emissions ...
www.acdelco.com/service/troubleshooting.jsp - Cached - Similar
WikiAnswers - Car Shaking Problems Questions including "How do you ...

What would cause a car to shake and sputter and lose power only under heavy .... Why does your car shake during idle and acceleration? .... Why would white smoke a gas smell and shaking of a vehicle occur all at the same time? ...
wiki.answers.com/Q/FAQ/482 - Cached - Similar
Car-Trouble.com : Symptoms : Free automotive diagnosis & forum.

Poor acceleration is felt as a lack of power when accelerating, resulting in a slow rise ... steering wheel, shifter, pedals, or anywhere else in the car as a very fast shaking. ... Fuel smell; Rotten Eggs smell; Sulfur smell; Oil smell ...
www.car-trouble.com/symptoms.html - Cached - Similar
VWvortex Forums: car shakes under acceleration (occassionally)

Apr 11, 2008 ... I have noticed that it shakes under moderate to heavy acceleration. As I let off the gas the shaking goes away. ...
forums.vwvortex.com/zerothread?cmd=print&id... - Cached - Similar
>troubleshooting

Noises, smells, leaks and operating changes are all signs that something could be wrong with ... Mild to severe ping, usually worse under acceleration and load. ... Car may also shake. Sluggish. Engine delivers limited power under load or at high speed. ... Continuous, heavy sulfur odor, like rotten eggs. Emissions ...
www.spitfireauto.com/id12.html - Cached - Similar
Car Shakes While Driving Questions

Car Shakes While Driving Questions Information Got a Car Repair Question? ... The vibration causes the passenger seat to shake a little, and I can feel it under my feet. ... The faster the acceleration, the more noticeable the shake! ...
www.2carpros.com/topics/shakes1.htm - Cached - Similar
__________________
Peace/Happiness to you
from `Space
Reply With Quote
  #3  
Old 09-03-2009, 11:46 AM
 
Trader Rating:(0)
Join Date: May 2008
Posts: 19
Default

Could it be the coil packs or ignition coil? I checked all 6 plugs and none of them were cracked.

Thanks for the reply KidSpace
Reply With Quote
  #4  
Old 09-04-2009, 09:57 AM
 
Trader Rating:(0)
Join Date: May 2008
Posts: 19
Default

Problem found.

Took it to a local shop and found the following problems:

1. Ingnition Coil Bad - Not sure which one, so I will replace them all
2. #3 Fuel Injector Bad

I will post back next week when I make the repairs.

Shop wanted to charge me $600 for parts and labor and perform a fuel injection clean with the BG kit for $119.

I will be able to do everything in my driveway for $160
Reply With Quote
  #5  
Old 09-04-2009, 10:00 AM
ChibiBlackSheep's Avatar

Monte Of The Month -- August 2014
5 Year Member3 Year Member1 Year Member

 
Trader Rating:(0)
Join Date: Sep 2008
Location: North Wales, PA
Posts: 22,984
mikerogers.design ChibiBlackSheep mikerogersdesigns ChibiBlackSheep ChibiBlackSheep thismikerogers
Send a message via AIM to ChibiBlackSheep
Default

Remember to lubricate the O-Rings on the Injectors when you put them back in so you don't tear one.
__________________

Daily Driver - 2013 IOM Camaro 1LS | LFX and M6
Reply With Quote
  #6  
Old 09-04-2009, 03:57 PM
 
Trader Rating:(0)
Join Date: May 2008
Posts: 19
Default

thanks chibiblacksheep.

I will be sure to do that. You recommend a certain lubricant?
Reply With Quote
  #7  
Old 09-04-2009, 05:25 PM
ChibiBlackSheep's Avatar

Monte Of The Month -- August 2014
5 Year Member3 Year Member1 Year Member

 
Trader Rating:(0)
Join Date: Sep 2008
Location: North Wales, PA
Posts: 22,984
mikerogers.design ChibiBlackSheep mikerogersdesigns ChibiBlackSheep ChibiBlackSheep thismikerogers
Send a message via AIM to ChibiBlackSheep
Default

dielectric grease.

Not much, but just put some on with you finger so it doesn't tear.
__________________

Daily Driver - 2013 IOM Camaro 1LS | LFX and M6
Reply With Quote
  #8  
Old 09-10-2009, 07:30 AM
 
Trader Rating:(0)
Join Date: May 2008
Posts: 19
Default

Replaced all 3 Coil Packs last night and no more shaking, no more flashing check engine light, and it drives a lot smoother. Car is idling very nice.

However, I am still experiencing a sluggish response when I accelerate rapidly and on the top end. (A minor popping condition in the exhaust) It acts like it is hesitating. It almost feels like one of the cylinders is still missing.

Drives great under normal acceleration.

I am going to replace the #3 fuel injector tomorrow and see if that resolves the issue.

Last edited by xman23; 09-10-2009 at 07:45 AM.
Reply With Quote
  #9  
Old 09-10-2009, 08:23 AM
ChibiBlackSheep's Avatar

Monte Of The Month -- August 2014
5 Year Member3 Year Member1 Year Member

 
Trader Rating:(0)
Join Date: Sep 2008
Location: North Wales, PA
Posts: 22,984
mikerogers.design ChibiBlackSheep mikerogersdesigns ChibiBlackSheep ChibiBlackSheep thismikerogers
Send a message via AIM to ChibiBlackSheep
Default

It does sound like it could be a fueling issue, but out of curiosity how does your air filter look?
__________________

Daily Driver - 2013 IOM Camaro 1LS | LFX and M6
Reply With Quote
  #10  
Old 09-10-2009, 11:17 AM
drewskie043's Avatar
 
Trader Rating:(0)
Join Date: Oct 2008
Location: St. Paul, MN
Posts: 432
Default

for future reference, whenever your check engine light flashes, it means there is a major cylinder misfire.
__________________
--Magnaflow Exhaust
--Cold Air Inductions, Inc. Intake
--Xenon Headlights and foglights
--Super White Interior LEDs
--Custom made stainless door sill plates
--Foglights added
--RS Badge Kit
--Front STB bar installed with custom brackets made by yours truly

http://i419.photobucket.com/albums/pp279/drewskie043/exhaust007.jpg

MCF Album:
http://montecarloforum.com/forum/members/drewskie043-4686-albums/
Reply With Quote
Old 09-10-2009, 11:17 AM
 
 
 
Reply

Tags
01, 2000, accelerating, acceleration, accellerating, carlo, check, engine, flashes, flashing, light, monte, shakes, shaking, sluggish, stall


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Advertising

Featured Sponsors
Vendor Directory
Our Sponsors

All times are GMT -5. The time now is 05:02 PM.

Internet Brands, Inc.



SEO by vBSEO ©2010, Crawlability, Inc.